// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})").unwrap();
let string = "PJSIP/117-AA01002-00000039
SIP/117-AA01002-00000039
SIP/1030-AA01002-00000039
PJSIP/10301-AA01002-00000039
Local/DIAL-8297225031@fromotherpbx-0000004e;2
Local/132-54-0@dialfromfollowme-00000022;2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}