#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)File\s\'(?<pathname>.+[\/\\])(?<filename>[^\\\/]+)\'\schecksum\schanged\."
Local $sString = "File '/apps/data/db.data' checksum changed." & @CRLF & _
"File 'c:\windows\system32\xpsservices.dll' checksum changed." & @CRLF & _
"File 'C:\filename\with\space in it.txt' checksum changed." & @CRLF & _
"File '/test /of space/inpath.txt' checksum changed." & @CRLF & _
"File '/test/of/ßàdSpecial/characters in path' checksum changed." & @CRLF & _
"File 'ß:\weirdhaving/abetacharacter/drive.name' checksum changed."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")