use strict;
my $str = 'File \'/apps/data/db.data\' checksum changed.
File \'c:\\windows\\system32\\xpsservices.dll\' checksum changed.
File \'C:\\filename\\with\\space in it.txt\' checksum changed.
File \'/test /of space/inpath.txt\' checksum changed.
File \'/test/of/ßàdSpecial/characters in path\' checksum changed.
File \'ß:\\weirdhaving/abetacharacter/drive.name\' checksum changed.';
my $regex = qr/File\s\'(?<pathname>.+[\/\\])(?<filename>[^\\\/]+)\'\schecksum\schanged\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}