#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([][^\\./-])(?=.*\1)"
Local $sString = "./[\folder]/this-is-a.test/fi^le.cxx.LAST[]^\/-.h"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)