const regex = new RegExp('([][^\\\\./-])(?=.*\\1)', 'gm')
const str = `./[\\folder]/this-is-a.test/fi^le.cxx.LAST[]^\\/-.h`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);