use strict;
my $str = './[\\folder]/this-is-a.test/fi^le.cxx.LAST[]^\\/-.h';
my $regex = qr/([][^\\./-])(?=.*\1)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";