import Foundation
let pattern = #"([][^\\./-])(?=.*\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"./[\folder]/this-is-a.test/fi^le.cxx.LAST[]^\/-.h"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)