import re
regex = re.compile(r"\b[a-zA-Z1-9]((([]!#$%^&*()])(?!\g<-1>))|[a-zA-Z1-9]){0,63}((?<![]!#$%^&*()])@)(\w+\.)+(com|net|gov|mil|org|edu)\b", flags=re.MULTILINE)
test_str = ("(850)867-5309\n"
"850-867-5309 \n"
"(850_867_5309)\n"
"850.867.5309\n"
"[Hello]\n"
"C:\\windows\\system32\n"
"!MrColdsnow@jimbob.steve.com\n"
"BaconTaters@osu.edu\n"
"1.2.3.4\n"
"11.22.33.44\n"
"111.222.111.222\n"
"192.168.0.5\n"
"1234.1234.1234.1234\n"
"956.458.875.259\n"
"...\n"
"123-45-6789\n"
"ABB\n"
"ABAB\n"
"The quick brown dog jumped over the lazy programmer.\n"
"There are fifty states in the United States.\n"
"Breathe because RegEx is easy.\n"
"42 ( Answer to the Ultimate Question of Life, the Universe, and Everything )\n"
"73 (the best number) ( 7 is the 4th prime number and 3 is the 2nd prime number (42) )\n"
" (not to mention, 73 is the 21st prime number and 37 is the 12th (both numbers mirrored) and\n"
" 73 in binary is 1001001 (a palindrome) )\n"
"bat cat hat rat brat chat\n"
"eat fat gat lat mat oat pat sat vat \n"
"my dog likes a good hotdog\n"
"dogs like hotdogs but not our \"person\" dogma\n"
"dog\n"
"2dog\n"
"snoop2dog\n"
"10\n"
"150\n"
"345\n"
"14\n"
"0789\n"
"7980\n"
"ICMP echo request\n"
"ICMP echo reply\n"
"deed peep noon Otto Abba\n"
"level kayak madam radar refer civic\n"
"redder revver\n"
"racecar rotator deified repaper reviver\n"
"List of trucks that are better than the F150:\n"
"1. GMC Sierra\n"
"2. Chevy Silverado\n"
"3. Toyota Tundra\n"
"4. Nissan Titan\n"
"5. Toyota Tacoma\n"
"6. GMC Canyon\n"
"7. Nissan Frontier\n"
"8. Jeep Gladiator\n"
"9. Honda Ridgeline\n"
"10. Chevy Cavalier\n"
"moose mouse mooooose m3se\n"
"Mississippi")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")