#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})\.){3}(?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})$"
Local $sString = "000.12.12.034" & @CRLF & _
"01.1.1.1" & @CRLF & _
"121.234.12.12" & @CRLF & _
"23.45.12.56" & @CRLF & _
"000.12.234.23.23" & @CRLF & _
"666.666.23.23" & @CRLF & _
".213.123.23.32" & @CRLF & _
"23.45.22.32." & @CRLF & _
"I.Am.not.an.ip" & @CRLF & _
"1.1.1.1" & @CRLF & _
"0.0.0.0" & @CRLF & _
"255.2.2.255" & @CRLF & _
"256.0.0.33" & @CRLF & _
"199.200.0.22" & @CRLF & _
"000" & @CRLF & _
"111" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
"1" & @CRLF & _
"00" & @CRLF & _
"11" & @CRLF & _
"99" & @CRLF & _
"90" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"292" & @CRLF & _
"999" & @CRLF & _
"255" & @CRLF & _
"266" & @CRLF & _
"299" & @CRLF & _
"256" & @CRLF & _
"199" & @CRLF & _
"244" & @CRLF & _
"" & @CRLF & _
"000.12.12.034" & @CRLF & _
"121.234.12.12" & @CRLF & _
"23.45.12.56" & @CRLF & _
"00.12.123.123123.123" & @CRLF & _
"122.23" & @CRLF & _
"Hello.IP" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")