package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})\.){3}(?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})$`)
var str = `000.12.12.034
01.1.1.1
121.234.12.12
23.45.12.56
000.12.234.23.23
666.666.23.23
.213.123.23.32
23.45.22.32.
I.Am.not.an.ip
1.1.1.1
0.0.0.0
255.2.2.255
256.0.0.33
199.200.0.22
000
111
0
00
1
00
11
99
90
2
3
4
292
999
255
266
299
256
199
244
000.12.12.034
121.234.12.12
23.45.12.56
00.12.123.123123.123
122.23
Hello.IP
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}