re = /[a-zA-Z]/m
str = 'I will always remember
The day you kissed my lips
Light as a feather
And it went just like this
No, it\'s never been better
Than the summer of 2002 (ooh)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end