$re = '/[^\p{Han}]+/u';
$str = 't你好
這是中國
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);