use strict;
my $str = '
“Don\'t cry because it\'s over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
';
my $regex = qr/(?s)tags:\s*(.+?)\n\s*\d/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}