import Foundation
let pattern = #"(?s)tags:\s*(.+?)\n\s*\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
“Don't cry because it's over, smile because it happened.”
?
Dr. Seuss
tags:
attributed-no-source,
cry,
crying,
experience,
happiness,
joy,
life,
misattributed-dr-seuss,
optimism,
sadness,
smile,
smiling
176513 likes
Like
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)