using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{2})?\d{6}(F|L|SDL?)?$";
string input = @"CA123456SDL
CA123456
123456
C123456SDL
123456F
123456L
123456SD
123456SDL
123456SDL
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}