#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+_\d+_\w+_(\d+)m_Length_(([0-9]*[.])?[0-9]+)_Width"
Local $sString = "Footballfield_01_CampNou_108m_Length_68.5_Width" & @CRLF & _
"Footballfield_02_Bernabeau_105m_Length_68.5_Width"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")