using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""email\\\\\\\"":\\\\\\\"".*?(?=,)";
string input = @"{
\\\""person\\\"":{\\\""name\\\"":{\\\""firstName\\\"":\\\""John\\\"",\\\""lastName\\\"":\\\""Doe\\\""},\\\""address\\\"":{\\\""street\\\"":\\\""100 Main Ave\\\"",\\\""city\\\"":\\\""Redwood City\\\"",\\\""usState\\\"":\\\""CA\\\"",\\\""zipCode\\\"":\\\""94061\\\"",\\\""country\\\"":\\\""United States\\\"",\\\""phones\\\"":[],\\\""emails\\\"":[],\\\""addressLines\\\"":[]},\\\""addresses\\\"":[],\\\""phones\\\"":[{\\\""phoneType\\\"":\\\""Home\\\"",\\\""phoneNumber\\\"":\\\""6500000000\\\""}],\\\""email\\\"":\\\""johndoe@gmail.com\\\"",\\\""dateOfBirth\\\"":\\\""1900/01/01\\\"",\\\""nationalId\\\"":\\\""100\\\"",\\\""gender\\\"":\\\""Male\\\""},\\\""credential\\\"":{\\\""userName\\\"":\\\""johndoe@gmail.com\\\"",\\\""password\\\"":\\\""Password\\\"",\\\""securityQuestion\\\"":\\\""Name of First Car?\\\"",\\\""securityAnswer\\\"":\\\""Volvo\\\""}\""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}