# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?s)
keyword1 .*?
(?:
(?: keyword1 | keyword2 )
(*SKIP) (*FAIL)
| keyword3
)
.*?
(?: keyword1 (*SKIP) (*FAIL) | keyword2 )
"""
test_str = ("List of keywords :\n\n"
"keyword1 = <page>\n"
"keyword2 = </page>\n"
"keyword3 = {{Infobox\n\n"
"Example A:\n\n"
"keyword1 = <page>\n"
"text to consider without keyword-Not3\n"
"keyword2 = </page>\n\n"
"Result => do not extract (or keep or split) this part.\n\n"
"Example B:\n\n"
"keyword1 = <page>\n"
"text to consider with keyword3\n"
"keyword2 = </page>\n\n"
"Result => extract (or keep or split) this part.")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.