// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^,\n]+(?:,|$)){2}([^,\n]+(?:,|$))*|^.*$").unwrap();
let string = "2.99
1.55763239875389,2.80373831775701,1.24610591900312
1.55763239875389,2.80373831775701,1.24610591900312,4.04984423676012,26.4797507788162,2.49221183800623,299";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}