import re
regex = re.compile(r"\\\"\d{1,3}cm\\\"", flags=re.MULTILINE)
test_str = ("\"<?xml version=\\\"1.0\\\" standalone=\\\"no\\\"?>\",\n"
"\"<svg xmlns=\\\"http://www.w3.org/2000/svg\\\" version=\\\"1.1\\\" width=\\\"1250cm\\\" height=\\\"1250cm\\\">\",\n"
"\"<desc>9W43OV00W8JKMA1IJNEYAM1WTG9AZH8K10LC</desc>\",\n"
"\"<g id=\\\"HMLW03D1BYIQ\\\" fill=\\\"red\\\">\",\n"
"\"<rect x=\\\"252cm\\\" y=\\\"252cm\\\" width=\\\"252cm\\\" height=\\\"252cm\\\"/>\",\n"
"\"<rect x=\\\"72cm\\\" y=\\\"72cm\\\" width=\\\"72cm\\\" height=\\\"72cm\\\"/>\",\n"
"\"<rect x=\\\"131cm\\\" y=\\\"131cm\\\" width=\\\"131cm\\\" height=\\\"131cm\\\"/>\",\n"
"\"<rect x=\\\"228cm\\\" y=\\\"228cm\\\" width=\\\"228cm\\\" height=\\\"228cm\\\"/>\",\n"
"\"<rect x=\\\"240cm\\\" y=\\\"240cm\\\" width=\\\"240cm\\\" height=\\\"240cm\\\"/>\",\n"
"\"<rect x=\\\"232cm\\\" y=\\\"232cm\\\" width=\\\"232cm\\\" height=\\\"232cm\\\"/>\",\n"
"\"<rect x=\\\"192cm\\\" y=\\\"192cm\\\" width=\\\"192cm\\\" height=\\\"192cm\\\"/>\",\n"
"\"<rect x=\\\"0cm\\\" y=\\\"0cm\\\" width=\\\"0cm\\\" height=\\\"0cm\\\"/>\",\n"
"\"<rect x=\\\"0cm\\\" y=\\\"0cm\\\" width=\\\"0cm\\\" height=\\\"0cm\\\"/>\",\n"
"\"<rect x=\\\"0cm\\\" y=\\\"0cm\\\" width=\\\"0cm\\\" height=\\\"0cm\\\"/>\",\n"
"\"<rect x=\\\"65cm\\\" y=\\\"65cm\\\" width=\\\"65cm\\\" height=\\\"65cm\\\"/>\",\n"
"\"<rect x=\\\"81cm\\\" y=\\\"81cm\\\" width=\\\"81cm\\\" height=\\\"81cm\\\"/>\",\n"
"\"<rect x=\\\"65cm\\\" y=\\\"65cm\\\" width=\\\"65cm\\\" height=\\\"65cm\\\"/>\",\n"
"\"<rect x=\\\"80cm\\\" y=\\\"80cm\\\" width=\\\"80cm\\\" height=\\\"80cm\\\"/>\",\n"
"\"<rect x=\\\"82cm\\\" y=\\\"82cm\\\" width=\\\"82cm\\\" height=\\\"82cm\\\"/>\",\n"
"\"<rect x=\\\"81cm\\\" y=\\\"81cm\\\" width=\\\"81cm\\\" height=\\\"81cm\\\"/>\",\n"
"\"</g>\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")