const regex = /^section_1:\s*(?<section_1>[a-z]+(?:\s&\s[a-z]+)*)\s*\|\s*section_2:\s*(?<section_2>[a-z]+(?:\s&\s[a-z]+)*)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^section_1:\\s*(?<section_1>[a-z]+(?:\\s&\\s[a-z]+)*)\\s*\\|\\s*section_2:\\s*(?<section_2>[a-z]+(?:\\s&\\s[a-z]+)*)$', 'gmi')
const str = `Section_1: hello & goodbye | section_2: kuku
Section_1: hello & goodbye & hola | section_2: kuku
Section_1: hello | section_2: kuku
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}