re = /^section_1:\s*(?<section_1>[a-z]+(?:\s&\s[a-z]+)*)\s*\|\s*section_2:\s*(?<section_2>[a-z]+(?:\s&\s[a-z]+)*)$/mi
str = 'Section_1: hello & goodbye | section_2: kuku
Section_1: hello & goodbye & hola | section_2: kuku
Section_1: hello | section_2: kuku
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end