package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/services/?(?:page/[0-9]+)?/?$`)
var str = `/services
/services/
/services/page/2
/services/page/140/
/service/page
/servicesx/page
/services/page
/services/page/
/services/pages
/services/pages/2/
/services/foo
/services/foo/page
/xyz/services/page/2
/services/page/4/foo`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}