import Foundation
let pattern = #"^/services/?(?:page/[0-9]+)?/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/services
/services/
/services/page/2
/services/page/140/
/service/page
/servicesx/page
/services/page
/services/page/
/services/pages
/services/pages/2/
/services/foo
/services/foo/page
/xyz/services/page/2
/services/page/4/foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)