#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\+\d )(?<!\+\d{2} )(?<!\+\d{3} )\b\d{9}\b"
Local $sString = "The number is +31 713176319 and 650068168 is another one." & @CRLF & _
"" & @CRLF & _
"+1 713176319" & @CRLF & _
"+971 713176319"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")