use strict;
my $str = '<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>';
my $regex = qr/(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)/p;
my $subst = '$0 <img src="imagem.jpg">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";