// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<p(.*?)>)([[:space:]]+?|.*?|[[:space:]]+?)(<\/p>)").unwrap();
let string = "<p>Some text 1</p>
<p>Some text 2</p>
<p>Some text 3</p>";
let substitution = "$0 <img src=\"imagem.jpg\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}