const regex = /[Ss_]{1,1}([0-9]{2,2})[Eex\ _]{1,1}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Ss_]{1,1}([0-9]{2,2})[Eex\\ _]{1,1}', '')
const str = `un gars une fille s01 ep05 chez psy 01.avi
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}