using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\+\+) # não aceita dois ""+"" seguidos
[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)* # username
@ # arroba
[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$ # domínio";
string input = @"a++@gmail.com
a+@gmail.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}