import re
regex = re.compile(r"""
^(?!.*\+\+) # não aceita dois "+" seguidos
[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)* # username
@ # arroba
[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$ # domínio
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("a++@gmail.com\n"
"a+@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")