const regex = /(\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\\b)', 'g')
const str = `VII
CMXL
XII
XVII
IV
MMMIII
MXI
MXIV
MM
MC
MM
I
VI
MX
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}