// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\b)").unwrap();
let string = "VII
CMXL
XII
XVII
IV
MMMIII
MXI
MXIV
MM
MC
MM
I
VI
MX
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}