# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[ ]+|[ ]+$//gm;t' <<< " Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged
Bye Bye
email: peter@provider.com
Cell 1+800 888 888
"