#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[ ]+|[ ]+$"
Local $sString = " Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged " & @CRLF & _
" Bye Bye " & @CRLF & _
" " & @CRLF & _
" email: peter@provider.com " & @CRLF & _
"Cell 1+800 888 888 " & @CRLF & _
" "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)