using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ ]+|[ ]+$";
string substitution = @"";
string input = @" Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged
Bye Bye
email: peter@provider.com
Cell 1+800 888 888
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}