import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ ]+|[ ]+$";
final String string = " Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged \n"
+ " Bye Bye \n"
+ " \n"
+ " email: peter@provider.com \n"
+ "Cell 1+800 888 888 \n"
+ " ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}