$re = '/^[ ]+|[ ]+$/m';
$str = ' Thanks for the help! I\'ve been trying to meet with Jessica but she has cancelled so many times that I\'m discouraged 
 Bye Bye    
    
 email: peter@provider.com   
Cell 1+800 888 888 
 ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;