// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ ]+|[ ]+$").unwrap();
let string = " Thanks for the help! I've been trying to meet with Jessica but she has cancelled so many times that I'm discouraged
Bye Bye
email: peter@provider.com
Cell 1+800 888 888
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}