$re = '/(?=_{20,}|From:|On\s\w{3},\s\w{3}\s\d{1,2},\s\d{4}\sat\s\d{1,2}:\d{2})/i';
$str = 'Great thank you
________________________________
From: Blake <blake@foursocial.uk>
Sent: Saturday, August 31, 2024 9:46:12 AM
To: blake hoang <bjh2004@hotmail.co.uk>
Subject: Re: Ignition. Campaign
Thanks , yes we can do it
---
Blake Junior
Managing Director | Foursocial.
blake@foursocial.uk<mailto:blake@foursocial.uk>
Submission Links<https://linktr.ee/foursocial1>
[https://ci3.googleusercontent.com/mail-sig/AIorK4yeSFbHM5imdVzOjDTr7LwNvS9gqpyQ83uajylr7mDBuRn5ymG1jlev6Zz8vvgQMzDLAYjFLcR7LVLu]
On Sat, Aug 31, 2024 at 9:45 AM blake hoang <bjh2004@hotmail.co.uk<mailto:bjh2004@hotmail.co.uk>> wrote:
Hey there let me know the fee';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);