#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\&)(?!.*<).*?(?=[A-Z])"
Local $sString = "<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE " & @CRLF & _
"4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet" & @CRLF & _
" <td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE 4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")