import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\&)(?!.*<).*?(?=[A-Z])";
final String string = "<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE \n"
+ "4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet\n"
+ " <td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE 4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}