const regex = /(?<=\&)(?!.*<).*?(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\&)(?!.*<).*?(?=[A-Z])', 'gm')
const str = `<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE
4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet
<td>ARMOIRE 6 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td><td>Longueur : 297 cm - Profondeur : 73 cm - Hauteur : 260 cm.</span><br></td></tr><tr><td><b><u>ARMOIRE 4 PORTES <span style="font-family: arial;"><u style="color: rgb(170, 170, 170);">:</td></tr><tr><td>Chevet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}