#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/github\.com\/(?<owner>[a-z\d](?:[a-z\d]|-(?=[a-z\d])){0,38})\/(?<repo>[a-z\d._-]{1,100})\/(issues|pull)\/(?<issueNumber>\d+)(?<issueComment>#issuecomment-(?<issueCommentNumber>\d+))?"
Local $sString = "https://github.com/spacehub-mn/spacehub/issues/new/choose" & @CRLF & _
"https://github.com/spacehub-mn/spacehub/issues/311"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")