import Foundation
let pattern = ##"https?:\/\/github\.com\/(?<owner>[a-z\d](?:[a-z\d]|-(?=[a-z\d])){0,38})\/(?<repo>[a-z\d._-]{1,100})\/(issues|pull)\/(?<issueNumber>\d+)(?<issueComment>#issuecomment-(?<issueCommentNumber>\d+))?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
https://github.com/spacehub-mn/spacehub/issues/new/choose
https://github.com/spacehub-mn/spacehub/issues/311
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)