package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$`)
var str = `a.b@c.de`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}