Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\d(\d?)(:\d\d)?(p|a)m
/
gm
Input 1
1
New
1:00, 1pm, 1:00pm, noon, 11:30am, 1130am 1pm wednesday wednesday tomorrow at noon today at 11 hot dog