$re = '/\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\d(\d?)(:\d\d)?(p|a)m/m';
$str = '1:00, 1pm, 1:00pm, noon, 11:30am, 1130am
1pm wednesday
wednesday
tomorrow at noon
today at 11
hot dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);