import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)export\s*(?<modifiers>(?:\s*declare|\s*abstract|\s*async)+)?\s*(?<declaration>class|const +enum|const|enum|function\*?|interface|let|namespace|type(?! *\{)|var)\s+(?<exports>(?:[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*(?=[\s=:;/({])(?!.*?,))|(?:[\w\t\n\r .,:$'"=-]+)|(?:[{[][\w\t\n\r .,:$'"-]+[}\]]))(?:\s*=\s*[$_\p{ID_Start}][$\u200C\u200D\p{ID_Continue}]*)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
export const CJS_SYNTAX_REGEX: RegExp = /pattern/gm;export const IGNORE_PATTERNS: string[] = [];
export declare const RESOLVE_EXTENSIONS: string[]
export enum Snack{}
export const enum Snack {}
export interface User {}
export class House {}
export declare abstract class House extends Building {}
export abstract class House {}
export async function run() {}
export async function* run() {}
export function foo() {}
export function* foo() {}
export const $foo = 42
export const $foo= 42
export namespace Foo {}
export type Foo = 'foo'
export let name1, name2/*, … */; // also var
export const name1 = 1, name2 = 2/*, … */; // also var, let
export function functionName() { /* … */ }
export class ClassName { /* … */ }
export function* generatorFunctionName() { /* … */ }
export const { name1, name2: bar } = o;
export const [ name1, name2 ] = array;
declare module 'module-name' {
export declare abstract class Building {}
export declare class House extends Building {}
}
"export const $foo = 42"
export default async function functionName() { /* … */ }
export default function functionName() { /* … */ }
export default function* generatorName() { /* … */ }
export default async function* generatorNameAsync() { /* … */ }
export default class ClassName { /* … */ }
export default abstract class ClassName { /* … */ }
export default function () { /* … */ }
export default async function () { /* … */ }
export default function* () { /* … */ }
export default async function* () { /* … */ }
export default class { /* … */ }
export default async () => {}
export default async arg => {}
export default () => {}
export default arg => {}
export default (arg) => {}
export default foo
export default foo;
export default 1 + 1;
// export const CJS_SYNTAX_REGEX
/**
* Resolvable file extensions.
*
* @example
* export const CJS_SYNTAX_REGEX
*/
export type Foo = 'foo'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)