#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(租赁)?.{0,9}确认(为)?使用权资产"
Local $sString = "租赁期开始日,本公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"租赁期开始日,对租赁确认使用权资产和租赁负债" & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债。" & @CRLF & _
"本集团在租赁期开始日对租赁确认使用权资产和租赁负债" & @CRLF & _
"公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"在租赁期开始日,本公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债。" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"本公司选择确认使用权资产和租赁负债," & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债。" & @CRLF & _
"对租赁确认使用权资产和租赁负债" & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债。" & @CRLF & _
"确认使用权资产和租赁负债" & @CRLF & _
"本集团对租赁确认使用权资产和租赁负债" & @CRLF & _
"确认为使用权资产,确认为租赁负债" & @CRLF & _
"本公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"公司租入资产所支付的租赁费,在不扣除免租期的整个租赁期内,按直线法进行分摊,计入当期费用" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"在租赁期开始日,公司对租赁确 认使用权资产和租赁负债" & @CRLF & _
"在租赁期开始日,本公司对租赁确认使用权资产,确认租赁负债。" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债" & @CRLF & _
"本集团在租赁期开始日对租赁确认使用权资产,租赁负债" & @CRLF & _
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")