# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(租赁)?.{0,9}确认(为)?使用权资产"
test_str = ("租赁期开始日,本公司对租赁确认使用权资产和租赁负债\n"
"租赁期开始日,对租赁确认使用权资产和租赁负债\n"
"本公司对租赁确认使用权资产和租赁负债。\n"
"本集团在租赁期开始日对租赁确认使用权资产和租赁负债\n"
"公司对租赁确认使用权资产和租赁负债\n"
"本公司对租赁确认使用权资产和租赁负债\n"
"本公司对租赁确认使用权资产和租赁负债\n"
"在租赁期开始日,本公司对租赁确认使用权资产和租赁负债\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债。\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
"本公司选择确认使用权资产和租赁负债,\n"
"本公司对租赁确认使用权资产和租赁负债。\n"
"对租赁确认使用权资产和租赁负债\n"
"本公司对租赁确认使用权资产和租赁负债。\n"
"确认使用权资产和租赁负债\n"
"本集团对租赁确认使用权资产和租赁负债\n"
"确认为使用权资产,确认为租赁负债\n"
"本公司对租赁确认使用权资产和租赁负债\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
"公司租入资产所支付的租赁费,在不扣除免租期的整个租赁期内,按直线法进行分摊,计入当期费用\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
"在租赁期开始日,公司对租赁确 认使用权资产和租赁负债\n"
"在租赁期开始日,本公司对租赁确认使用权资产,确认租赁负债。\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债\n"
"本集团在租赁期开始日对租赁确认使用权资产,租赁负债\n"
"在租赁期开始日,公司对租赁确认使用权资产和租赁负债。\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.